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Introduction 
Management Studio is the primary tool for developing Transact-SQL queries in 
Microsoft® SQL Server™ 2005. This white paper will introduce you to Management 
Studio Transact-SQL editing facilities, highlighting some of its more interesting and 
compelling new features for Transact-SQL development. You'll also learn how 
Management Studio differs from, and improves on, SQL Server 2000 Query Analyzer. 
You should be familiar with how to start and operate SQL Server 2005 Management 
Studio, how to connect to a SQL Server 2005 instance, and how manipulate the various 
windows in Management Studio. 

Note   All references to Query Analyzer are to the version that comes with SQL 
Server 2000 SP3. 

General Features of Query Editing in Management 
Studio 

Management Studio integrates query editing across all SQL Server database products. 
When you start a new query from the New Query toolbar button or by selecting New 
Query from the File menu, and you will immediately notice that you can create and 
edit queries for SQL Server, Analysis Services, and SQL Server 2005 Mobile Edition. 
When you work with SQL Server queries, Management Studio invokes the Transact-SQL 
code editor. When you work with Analysis Server queries, Management Studio invokes 
the MDX, DMX, and XMLA editors, and when you work with SQL Server Mobile queries, 
it invokes a special code editor which covers the mobile subset of the Transact-SQL 
language. The focus of this paper will be on using Management Studio to edit Transact-
SQL queries. 

Before focusing in on Transact-SQL queries, it's useful to draw attention to some 
general features of Management Studio that stand out in contrast to Query Analyzer. 
One of the more striking features of Management Studio is that you can now edit in 
either a connected or disconnected mode: when you start a query, you are prompted 
for a connection, but if you decline you may still continue editing. You can even drop or 
change a connection during your editing session without having to save and reopen the 
query. This allows you to develop code offline, or successively connect to multiple SQL 
Servers while in the same query window. 

When you work with queries in a connected mode, Management Studio uses the SQL 
Native Client to connect to SQL Server, Analysis Server, or SQL Server Mobile. 
Management Studio is developed using Microsoft Visual Studio® managed code, and 
while it resembles Visual Studio in many ways, it is a distinct tool. Management Studio 
supports creating and editing Transact-SQL, Analysis Services, and SQL Server Mobile 
queries, but you must use Visual Studio to develop SQL CLR code.  

You can also open files for editing in Management Studio, and pick from text, query, 
and XML file types. For example, if you invoke the Open dialog from the File menu to 
open a text file, Management Studio will not prompt you for a connection, and will open 
a plain text editor.  
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Managing Transact-SQL Code 
There are two basic ways to edit Transact-SQL code in Management Studio: 
interactively from the database, or through script files. You can interactively edit 
database Transact-SQL code objects (such as stored procedures, triggers, and 
functions) using Object Explorer, or you can edit Transact-SQL scripts saved as disk 
files and optionally included in projects. Both methods employ the Management Studio 
query editing utility. 

Directly Editing Database Code 
The Management Studio Object Explorer is a natural companion for interactively editing 
Transact-SQL code, and you will often want to keep it available, whether docked or 
hidden, while you are editing Transact-SQL queries. You can use Object Explorer to 
start a new query from the current connection without having to fill in connection 
information in the Connection Dialog. Just drill down to a user database, right-click the 
database name, and choose New Query.  

You can interactively edit the Transact-SQL code embedded in a database using the 
Management Studio Object Explorer. When you drill down into the Programmability 
node of a database in Object Explorer, and right-click the stored procedure, trigger, or 
function node, you can use the New option to invoke the Query Template appropriate 
for that object. When you drill further down to a particular stored procedure, trigger, or 
function, you can right-click the node, pick the Modify option, and edit the object using 
an ALTER script. When you are creating a new object, the Query Template for the 
object will be loaded. Figure 1, for example, shows the Object Explorer, the Template 
Explorer, and the associated CREATE PROCEDURE template for a new stored procedure.  

 

Figure 1: You can use the Object Explorer to create a new Transact-SQL code 
object using a query Template. 
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When you create a new database code object using Object Explorer, Management 
Studio invokes the associated template having the (New Menu) notation, as shown in 
the Template Explorer for the Create Stored Procedure template in Figure 1.  

To add a comment or other notation for the code object, click Properties on the 
shortcut menu, and then choose the Extended Properties tab. You can also script the 
object using the Script <object> as option on the shortcut menu.  

When you use the Object Explorer to create a new or change an existing database code 
object, you are editing without using a disk-based script file. Therefore you are not 
associating your code with a project or solution, or with source code control. If you 
execute the query, your changes will be immediately applied to the database.  

You can also edit database code objects using file-based editing facilities in 
Management Studio. Editing Transact-SQL scripts allows you to develop Transact-SQL 
code objects that are subject to change-control practices.  

Script File Editing 
You can edit Transact-SQL script files individually from disk, or through SQL Server 
solutions and projects. Just as with Query Analyzer, you can create and modify 
individual script files, and save a new query as an isolated script file in Management 
Studio. Also as with Query Analyzer, you can check individual files out of a source code 
control system before editing, and check them back in when you are finished.  

Solutions and Projects 
New in Management Studio is the ability to organize your Transact-SQL script files into 
solutions and projects, and integrate those solutions and projects with source code 
control. A Management Studio solution organizes multiple projects as a single unit of 
work. Each project you create is associated with only one query type: SQL Server, 
Analysis Services, or SQL Server Mobile. Since every solution must have at least one 
project, you start a solution by first picking a project. Within a given project, you can 
store items concerning connection information, query script files, and miscellaneous 
files.  

Note   Management Studio solutions and projects are similar to, but not compatible 
with, Visual Studio solutions and projects. 

If you begin a new SQL Server query outside a project, Management Studio will start a 
new default Solution called "Solution1" with no projects. However, the best way to 
create a new solution is to start by creating a new project. Just open the File menu,  
select New, and then Project. The resulting dialog box allows you to choose a new 
project type, name, and solution name. If you want to include multiple projects in a 
solution, make sure you give the solution a different name from your project, as shown 
in Figure 2. 
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Figure 2: You can name a new solution when creating a new project, and also 
specify a solution and project location. 

While you can have only one solution open at a time, any solution can contain multiple 
projects of any project type. For more information about solutions and projects, see 
"Introduction to Solutions, Projects, and Items" in SQL Server Books Online. 

Management Studio integrates solutions and projects with source code control systems, 
provided your source code control system provides you with a compatible plug-in. You 
can then configure the source code control system in the Options dialog box (to display 
this dialog box, open the Tools menu and select Options). The Source Control/Plug-in 
Selection node in the selection tree presents the dialog box where you can specify the 
current source code control plug-in. Once you have set up integration with source code 
control, you can add the SQL Server solution to the source code system, and check it 
back out. You can check out the entire solution or just one project at a time. When you 
create new SQL Server queries in Solution Explorer, a Pending Checkins dialog box will 
assist you in determining what files will be checked in. 

For example, if you have installed the Microsoft Visual SourceSafe 6.0 client 
components on your computer, SQL Server 2005 Management Studio will automatically 
detect that the VSS plug-in is available. As previously noted, you can find the VSS plug-
in listed in the Options dialog box, by selecting the Source Control and then Plug-in 
Selection node. Also, the Source Control option on the File menu becomes active; 
from there you can add an existing Management Studio solution to source control, or 
open a Management Studio directly from source control. You can enable multiple source 
control systems, and change from one to another.  
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SQL CMD Scripts  
You can also run and debug SQLCMD queries using the Management Studio Transact-
SQL editor. When you toggle the SQLCMD button, Management Studio will recognize 
and execute SQLCMD-specific commands in addition to Transact-SQL commands. The 
major SQLCMD commands such as :SETVAR, :CONNECT, and :R are all executed by 
Management Studio when it is in SQLCMD mode. You can step through SQLCMD scripts 
batch by batch, or even line by line, effectively using Management Studio as a 
debugger for SQLCMD scripts.  

Using the Transact-SQL Code Editor 
Editing Transact-SQL code in SQL Server 2005 Management Studio is very similar to 
editing it in SQL Server 2000 Query Analyzer, but you will notice a number of 
enhancements to the authoring experience.  

Editing Features 
When you edit Transact-SQL code in Management Studio, you will see the same color 
syntax highlighting and editing options that you are familiar with from SQL Server 2000 
Query Analyzer. You can now redo an edit, in addition to undoing it. You also have 
enhanced find and replace dialog boxes, which allow you to search based on regular 
expressions or wild cards, as well as search and replace across files.  

Note  Management Studio does not have a tool corresponding to Query Analyzer's 
Object Search dialog box, but you can filter objects in the Object Explorer view. 

Additional editing options on the Edit menu in Management Studio include tabify and 
untabify options (which convert tabs to spaces and back), as well as an option for 
deleting horizontal white space. Also new is the ability to toggle word wrap on or off, 
and toggle whether to use a word wrap visual glyph. You can configure word wrap in 
the by opening the Tools menu and selecting Options, then Text Editor, then All 
languages. 

Keyboard Shortcuts 

You can comment and uncomment, and indent and un-indent text using buttons on the 
default Standard toolbar. However, Management Studio standard keyboard shortcuts 
for commenting and uncommenting Transact-SQL code have changed. Rather than 
using CTRL+SHIFT+C to comment, and CTRL+SHIFT+R to uncomment, Management 
Studio by default uses CTRL+K followed by CTRL+C for commenting, and CTRL+K 
followed by CTRL+U for uncommenting. To comment code, just hold down the control 
key, then press K followed immediately by C, without releasing the control key. (See 
"SQL Server Management Studio Keyboard Shortcuts" in SQL Server Books Online.)  

Note   You can change the Management Studio keyboard shortcut scheme from 
Standard to SQL Server 2000 by opening the Tools menu and selecting Options, 
then Environment, then Keyboard. You can define custom keyboard shortcuts in 
the Query shortcuts pane. 
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Window Management 

In Management Studio, you can work with two styles of query editing windows: tabbed 
or MDI Environment. The default setting is for tabbed windows, and you can select any 
open query window by selecting its tab. You can change the window layout to MDI 
windows in the Tools/Options dialog, in the Environment option. When you do this, 
Management Studio will automatically restart, but preserve all your connections and 
open windows. 

Note   Because Management Studio has many windows available, you may find it 
convenient to make the query editing window full screen. You can switch to full 
screen by using the SHIFT+ALT+ENTER keyboard shortcut, or you can use the View 
menu. To reset your windows back to the default setting, open the Window menu 
and click Reset Window Layout. 

You can view query windows tiled vertically or horizontally by right-clicking a query 
window's tab and choosing either New Horizontal Tab Group or New Vertical Tab 
Group. Once you have done this, you can use the ALT+SHIFT+ENTER keyboard 
shortcut to maximize the query windows to get the tiled effect. Figure 3 shows two 
query windows tiled side by side using the Vertical Tab Group maximized with the 
ALT+SHIFT+ENTER command. 

 

Figure 3: You can align two or more query windows by right clicking the Query 
tab and choosing New Horizontal/Vertical Tab Group, and maximize the 
windows with ALT+SHIFT+ENTER. 
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Working with Query Results 
You can still use F5, ALT+X, or CTRL+E to execute queries, in addition to the Execute 
button on the Query toolbar. Similarly, you can direct results to text, grid, or a file. 
When you direct results to a grid, you can cause query results to be displayed in a 
separate tab window, and you can make this change apply to the next opened query 
window using the Options dialog box (open the Tools menu and select Options). In the 
tree view of that dialog box, drill down to Query Results, SQL Server, and Results to 
Grid. Then check the Display results in a separate tab option. The tabs will then 
appear at the top of the query window. 

Although there is no toolbar icon associated with toggling the results window on or off 
in Management Studio, as in Query Analyzer, the CTRL+R command will still have the 
same effect. You can also use the Hide/Show Results Pane option on the Window 
menu. 

Analyzing Queries 
Management Studio adds new features in support of query analysis. In addition to the 
familiar graphical and textual showplan output, you can also direct showplan output to 
XML. The Database Tuning Advisor replaces the Index Tuning Wizard, and Client 
Statistics have a couple new features. 

Graphical Query Plans 
Just as in Query Analyzer, you can visually inspect the estimated and actual query plans 
by using buttons on the Standard toolbar, as well as clicking options on the Query 
menu. You will notice that Management Studio shows a revised set of icons for 
analyzing a query plan. In particular, operators are shown in blue, cursor physical 
operations in yellow, and language elements in green. The fly-over display on top of 
each node in the graphical query plan shows the operation's information more plainly, 
though to find the object (table or index) in question, you need to access the Properties 
page for the given node. (For a complete list of graphical query plan icons, see 
"Graphically Displaying the Execution Plan Using SQL Server Management Studio" in 
SQL Server Books Online.) 

Note   You can zoom in on a large query plan using the + sign in the lower right 
hand corner of the graphical query plan window. 

You can also direct showplan output to XML. If you invoke the command,  

SET SHOWPLAN_XML ON 

and execute a query with results to grid, the results set will contain the XML showplan 
as an XML document returned in a one-row, one-column table. To view the showplan's 
XML format, just click on the link in the plan's cell and Management Studio will open the 
plan in its XML editor. 

You can save the query plan in a portable format for viewing graphically. Right-click the 
internal link in the cell and save it with a .sqlplan extension. You can then open the file 
by clicking Open on the File menu, and Management Studio will display the graphical 
query plan. You can now send query plans in XML output using the .sqlplan extension to 
others for review without requiring a connection to the actual database. 
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The Database Tuning Advisor 
The SQL Server 2005 Database Tuning Advisor replaces the legacy Index Tuning 
Wizard. You can invoke it for selected queries from the Query menu, or using the 
CTRL+I keyboard shortcut. (You can invoke the Database Tuning Advisor directly from 
the Tools menu.)  

Client Statistics 
Client statistics are useful in determining how much time the network and client 
components contribute to the total response time of a query. Management Studio 
supports collecting client statistics from the SQL Editor Toolbar as well as from the 
Query menu. The Client Statistics utility gives you the option to reset the statistics, as 
well as to display up to 10 of the most recent trial runs, along with the average values. 
You can use SHIFT+ALT+S to set client statistics on, or choose the Client Statistics 
option from the Query menu, from which you can also reset client statistics. Each trial 
result is listed along with the average results over all trials. A new client statistic, total 
execution time, is added to Time Statistics.  

Configuring Management Studio for Transact-SQL 
Editing 

Management Studio has three major configuration options that affect Transact-SQL 
query editing.  

The Tools/Options dialog 
You will find most Management Studio configuration options in the Options dialog box 
(open the Tools menu and select Options). This dialog box serves as a central location 
for Management Studio default options for all query editing. When you change an 
option related to SQL Server queries, just as in Query Analyzer, your changes will affect 
the default settings for all subsequent queries. However, configuration changes vary as 
to when they take effect. Some of the choices vary depending upon the type of queries 
(Transact-SQL, Analysis Services, SQL Server Mobile, etc.) that you want to configure. 
Sometimes changes are applied immediately to all your query windows, sometimes only 
to subsequent windows, and sometimes Management Studio must restart itself to apply 
the change. 

Note   Management Studio does not provide the ability to manage table indexes or 
table statistics from the Tools menu. These operations have been moved to the 
Object Explorer: just drill down in the Object Explorer to the Indexes or Statistics 
node of the table in question. 

In the General dialog box (open the Tools menu, click All Languages, then General), 
notice the options for Statement Completion. These options affect IntelliSense® 
behavior. Here also is where you can specify word-wrap options and permit single-click 
URL navigation within SQL queries. 

Note   IntelliSense is not active for Transact-SQL queries in SQL Server 2005 
Management Studio. It is active, however, for the XML and MDX editors. (You can 
further configure XML editing in the Text Editor/XML node of the Options dialog 
tree.) 
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Customizing Toolbars  
The Customize option on the Tools menu in Management Studio invokes the 
Customize dialog box, which allows you to customize your toolbar appearance. For 
example, if you would like to have a toolbar button that will toggle the results pane, on 
the Commands tab of the Customize window, select the Window category, and scroll 
down to the Show Results Pane command. Select the command and drag it to the 
location on the desired toolbar.   

Query Options 
You can set certain options for the current query window by invoking the Query Options 
dialog box. You can open this dialog box from the Query menu, or by using the 
CTRL+SHIFT+O keyboard shortcut, or by clicking the Query Options button on the 
Query toolbar. Use the Query Options dialog box to set options for both the execution 
of queries and the display of results, but on a query window basis. The options in this 
dialog box are a subset of the options in the Options dialog box, accessed from the 
Tools menu: the Execution options are identical to those found in the 
Tools/Options/Query Execution/SQL Server dialog box, and the Results options are the 
same as those found in the Query Results/SQL Server dialog box. The difference is that 
when you set options in the Query Options dialog, you are only affecting the current 
query window. 

Conclusion 
SQL Server 2005 Management Studio offers some compelling enhancements for 
developing Transact-SQL queries. In particular, you no longer need to have a 
connection to a physical SQL Server in order to edit a Transact-SQL query, and you can 
connect, disconnect, or change connections all within the same editing session. You can 
organize your Transact-SQL script files into solutions and projects, and integrate those 
solutions with source code control systems. Above all, you can export XML showplan 
files to disk, saving them with the .sqlplan extension, and reload them to view the 
graphical query plan. Management Studio is similar enough to Query Analyzer that you 
will find familiar ground with significant new assistance in editing Transact-SQL code. 
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